The Mystera Legacy app

Home Forums Mystera Discussion The Mystera Legacy app

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #17947

    Lvl 205 USEast2
    Posts: 3

    The mystera legacy app won’t load for me after the recent update, it stays on the screen that says “-initializing-” with rest of the screen being black, so I can’t play anymore on my phone unless I get on the browser. Please fix this, thank you. Is anyone else having problems opening the app?


    Lvl 7 USWest
    Posts: 157

    update the app in the play store


    Lvl 205 USEast2
    Posts: 3

    I have tried that, I even uninstalled and reinstalled the app, but the problem still peresists. I should have included that in my original post


    Lvl 98 USTexas
    Posts: 1

    I uninstalled the app, now on getting a your phone is not compatible message. It worked fine before the update.


    Lvl 17 USTexas
    Polar Bear
    Posts: 35

    i got stuck on initializing page too, also maybe it was my brower my mouse or what idk, but when i click too fast on inventory box, it got stuck and i couldnt do anything but move up down left right. can do stuff using hotkeys, maybe my mouse, but mouse worked well when i click on dpad.
    must relog to fix the problem. time consuming DX

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘The Mystera Legacy app’ is closed to new replies.